路由器的部分配置如下:
Class-map match-any GOLD
match ip precedence ef
class-map match-any SILVER
Match ip dscp af31
Policy-map Branch
Class GOLD
Priority percent 20
Class SILVER
bandwidth percent 15
random-detect dscp-based
interface Serial0/1
description PPP link to BRANCH bandwidth 1536
ip address 10.200.40.1 255.255.255.252
encapsulation ppp
路由器配置VOICE数据流到优先级队列中,但发现并没有起到作用,可能什么原因?()
下面是路由器RTA的部分配置:
[RTA-ospf-100]ospf 100
[RTA-ospf-100]silent-interface gigabitethernet1/0/0
对于此部分配置描述错误的是()
在MSR路由器RTA上执行displaospfvlink命令,路由器输出如下:
OSPFProcess100withRouterID3.3.3.3
VirtualLinks
Virtual-linkNeighbor-ID->2.2.2.2,Neighbor-State:FullInterface:20.0.0.1(GigabitEthernet0/1)
Cost:1State:P-2-PTpe:VirtualTransitArea:0.0.0.1
Timers:Hello10,Dead40,Retransmit5,TransmitDela1
从以上输出可以判断()。
class Waiting implements Runnable {
boolean flag = false;
public synchronized void run() {
if (flag) {
flag = false;
System.out.print("1 ");
try { this.wait(); } catch (Exception e) { }
System.out.print("2 ");
}
else {
flag = true;
System.out.print("3 ");
try { Thread.sleep(2000); } catch (Exception e) { }
System.out.print("4 ");
notify();
}
}
public static void main(String [] args) {
Waiting w = new Waiting();
new Thread(w).start();
new Thread(w).start ();
}
}
以下哪两项是正确的?()
在Java语言中,如果你有下面的类定义:
abstract class Shape {
abstract void draw(); }
Class Square extends Shape {}
如果你试图编译上面的代码会发生()。
路由器的部分配置如下:
Class-map match-any GOLD
match ip precedence ef
class-map match-any SILVER
Match ip dscp af31
Policy-map Branch
Class GOLD
Priority percent 20
Class SILVER
bandwidth percent 15
random-detect dscp-based
interface Serial0/1
description PPP link to BRANCH bandwidth 1536
ip address 10.200.40.1 255.255.255.252
encapsulation ppp
路由器配置VOICE数据流到优先级队列中,但发现并没有起到作用,可能什么原因?()
数据库mydb中有关系表student,其结构如下:
student(sno学号,sname姓名,sex性别,birthday生日)
现编写一个学生信息浏览程序,设计界面和运行界面如下图所示:
在下划线处填写相应数据库组件的属性值:
Database1. DatabaseName : mydb
Table1. DatabaseName : mydb T
able1. TableName : student
Table1. Active :(①)
Datasource1.DataSet :(②)
DBNavigator1. DataSource : (③)
DBEdit2. DataSource :(④)
DBEdit2. DataField :(⑤)
class java {
public static void main(String [] java) {
for (int Java = 1; Java 〈 java.length; Java++)
System.out.print("java ");
}
}
和命令行:
java java java java java
结果为:()
如下所示的这段CSS样式代码,定义的样式效果是()
a:link {color: #ff0000;}
a:visited {color: #00ff00;}
a:hover {color: #0000ff;}
a:active {color: #000000;}
其中#ff0000为红色,#00000为黑色,#0000ff为蓝色, #00ff00为绿色
You are designing a top-level OU structure to meet the business and technical requirements.
Which top-evel OU or OUs should you use? ()
为将数组myArray的长度由3改为6,现采取以下编码:
int[]myArray=new int [3];
myArray=new int[6];
代码执行后,以下叙述哪项是正确的?()
public class TestOne {
public static void main (String[] args) throws Exception {
Thread.sleep(3000);
System.out.println(”sleep”);
}
}
What is the result?()
public class A extends Thread {
A() {
setDaemon(true);
}
public void run() {
(new B()).start();
try {
Thread.sleep(60000);
} catch (InterruptedException x) {}
System.out.println(“A done”);
}
class B extends Thread {
public void run() {
try {
Thread.sleep(60000);
} catch (InterruptedException x) {}
System.out.println(“B done”);
}
}
public static void main(String[] args) {
(new A()).start();
}
}
What is the result?()
阅读以下代码:
public class Test{
public static void main(){
System.out.println(“x=”+x); } }
请问,代码运行的结果是?()
public class Car {
private int wheelCount;
private String vin;
public Car(String vin) {
this.vin = vin;
this.wheelCount = 4;
}
public String drive() {
return “zoom-zoom”;
}
public String getInfo() {
return “VIN: “+ vin + “wheels: “+ wheelCount;
}
}
And:
public class MeGo extends Car {
public MeGo(String vin) {
this.wheelCount = 3;
}
}
What two must the programmer do to correct the compilation errors?()
public class X {
public static void main (String[]args) {
string s = new string (“Hello”);
modify(s);
System.out.printIn(s);
}
public static void modify (String s) {
s += “world!”;
}
}
What is the result?()
现有:
public interface A {}
以下哪项声明是合法的?()
现有:
public interface A {}
以下哪项声明是合法的?()
What is wrong with the following code?()
class MyException extends Exception {}
public class Qb4ab {
public void foo() { try { bar(); } finally { baz();
} catch (MyException e) {}
}
public void bar() throws MyException {
throw new MyException();
}
public void baz() throws RuntimeException {
throw new RuntimeException();
}
}
class Birds {
public static void main(String [] args) {
try {
throw new Exception();
} catch (Exception e) {
try {
throw new Exception();
} catch (Exception e2) { System.out.print("inner "); }
System.out.print("middle ");
}
System.out.print("outer ");
}
}
结果为:()
现有:
class Birds {
public static void main (String [] args) {
try {
throw new Exception () ;
} catch (Exception e) {
try {
throw new Exception () ;
} catch (Exception e2) { System.out.print ("inner "); }
System. out.print ( "middle" ) ;
}
System.out.print ("outer") ;
}
}
结果是()
public class X {
public static void main(String [] args) {
try {
badMethod();
System.out.print(“A”);
}
catch (RuntimeException ex) {
System.out.print(“B”);
}
catch (Exception ex1) {
System.out.print(“C”);
}
finally {
System.out.print(“D”);
}
System.out.print(“E”);
}
public static void badMethod() {
throw new RuntimeException();
}
}
What is the result?()
public class Test {
public static void aMethod() throws Exception {
try {
throw new Exception();
} finally {
System.out.println(“finally”);
}
}
public static void main(String args[]) {
try {
aMethod();
} catch (Exception e) {
System.out.println(“exception”);
}
System.out.println(“finished”);
}
}
What is the result?()
现有:
void topGo() {
try {
middleGo();
} catch (Exception e) {
System.out.print("catch");
}
}
void middleGo() throws Exception {
go();
system.out.print("late middle");
}
void go() throws ExceptiOn {
throw new Exception();
}
如果调用 topGo () ,则结果为:()
import java.io.IOException;
public class ExceptionTest(
public static void main (Stringargs)
try (
methodA();
) catch (IOException e) (
system.out.printIn(“Caught IOException”);
) catch (Exception e) (
system.out.printIn(“Caught Exception”);
)
)
public void methodA () {
throw new IOException ();
}
What is the result?()
现有:
class ThreadExcept implements Runnable {
public void run() { throw new RuntimeException("exception "); }
public static void main(String [] args) {
new Thread(new ThreadExcept()).start();
try {
int x = Integer.parseInt(args[0]);
Thread.sleep(x);
System.out.print("main ");
} catch (Exception e) { }
}
}
和命令行:
java ThreadExcept 1000
哪一个是结果?()
Class TestException
1. public class TestException extends Exception {
2. } Class a:
1. public class a {
2.
3. public String sayHello(String name) throws TestException {
4.
5. if(name == null) {
6. throw new TestException();
7. }
8.
9. return “Hello “+ name;
10. }
11.
12. }
A programmer wants to use this code in an application:
45. A a=new A();
46. System.out.println(a.sayHello(”John”));
Which two are true?()
在J2EE中,有如下代码在Servlet1.Java中
Import javax.servlet.*;
Import javax.servlet.http.*
Import java.io.IOException;
Import java.io.PrintWriter;
Public class Servlet1 extends HttpServlet{
Public void init () throw ServletException {}
Public void service(HttpServletRequest request,
HttpServletResponce response) throws ServletException,IOException{
PrintWriter out=response.getWriter();
Out.println(“hello!”); } }
假如编译Servlet要具备的环境都已经建立好。现在用完全正确的命令编译该文件,对于以下成熟正确的是()
某路由器路由表如下:
此时当该路由器从以太网口收到一个发往11.1.1.1主机的数据包时,路由器如何处理()
Which statements concerning the relationships between the following classes are true?()
class Foo { int num;
Baz comp = new Baz();
}
class Bar { boolean flag;
}
class Baz extends Foo {
Bar thing = new Bar();
double limit;
}
int index = 1;
boolean[] test = new Boolean[3];
boolean foo= test [index];
What is the result?()
int index = 1;
boolean test = new Boolean;
boolean foo= test [index];
What is the result?()
String foo = “blue”;
Boolean[]bar = new Boolean [1];
if (bar[0]) {
foo = “green”;
}
What is the result? ()
免费的网站请分享给朋友吧